6 posts / 0 new
Last post
pulkkinen@ultim...
onHeadsetStateChanged stops responding
Hi, I integrated some simple controls for Plantronics Savi-740, with c#. I mainly listen events like battery change, mute, talk button pressed etc. However, onHeadsetStateChanged doesn't always seem to work. If I rapidly take the headset from the dock and put it back, maybe repeat it couple of times, events stop coming from onHeadsetStateChanged-delegate. events start to reappear after I press the left-most button from the dock (voip-button) OR change the active link state to COMLineType.LineType_VOIP from the code. Is this known issue or is there somehting I missed? I used the Plantronics SDK first steps-project as the base of my integration, same bug happens there as well

lcollins
Hi,
I have attempted to reproduce this but I cannot using the preferred C# sample code here:
https://github.com/pltdev/pdc/tree/master/C%23%20Sample
With Savi 700 series product I removed and replaced headset from the dock lots of times very rapidly.
Note: It is slow to detect the Docked state, but once it did, it continued to reflect Undocked instantly I removed the headset as expected via the onHeadsetStateChanged event.

Could you try with this code?
Also make sure you use the latest SDK and Plantronics Hub software.
SDK: http://developer.plantronics.com/softphone-integration-sdks
Hub: http://www.plantronics.com/software

Let us know.

Thanks,
Lewis.

pulkkinen@ultim...
Hi, I was able to reproduce it with the updated sample & sdk as well, although it was bit harder to reproduce. We have Savi W740 with latest firmware... Basically it happens when you dock it and immediately remove it, might take couple of tries to get it reproducing. After I got it to reproduce, it somehow started resending  HeadsetStateChange_UnDocked & HeadsetStateChange_Docked messages after a minute or so... I also noticed, that the versio number of Interop.Plantronics.dll had not changed in latest sdk, but that's propably the way it should be?

lcollins
Hi,
Could you confirm:
- The Plantronics Hub version > under Help > About
- The Plantronics SDK version you have compiled against (version of Interop.Plantronics.dll - mine is: 3.10.51830.6359 and is referenced in: C:\Program Files (x86)\Plantronics\Spokes3G SDK\Interop.Plantronics.dll, that being the default SDK install folder)
- The Savi W740 firmware versions (click About Tab of Hub, click Firmware All Components > View)
- That Plantronics Hub is successfully connected to the tenant server. This is under Help > Support > Troubleshooting Assistance > Last attempt - should read "Success"
Thanks,
Lewis.
 

pulkkinen@ultim...
Actually, reboot seemed to fix the issue, maybe it was still using the old dll's when I was testing...

pulkkinen@ultim...
I was able to reproduce similar issue with youd sdk. Calling COMDeviceListener.SetActiveLink repeatedly makes the device unresponsive to any other similar calls until user presses the voip-link button in top of the device. I can send the modified c# sample project to you guys if you need it ( basically I just added new command to DeviceListenerCommand-class to set the active link, with a boolen to tell the function which state tje link should go )

Add new comment